• April 12, 2020 at 3:57 pm #2409
    Ganbold TsGanbold Ts

    I installed it in my son’s Windows 10, but accidentally used the activation key that he used in his Mac mini.And Animation Paper is not working on his Windows 10. I tried even to remove and install again, it doesn’t ask for activation key and still the same problem, even I click/run Animation Paper, it doesn’t appear.Do you know what the problem is?Please let me know how to solve this issue.
    thanks a lot,


    April 12, 2020 at 7:42 pm #2413
    Niels Krogh MortensenNiels

    That is interesting. That it is not appearing at all is strange behaviour. I will have to get back to you on this…

    April 13, 2020 at 11:04 am #2423
    Michael ScourfieldMichael Scourfield

    I’m using animation paper on windows 10 without a problem.

    April 17, 2020 at 2:01 pm #2494
    Ganbold TsGanbold Ts

    Still can’t run Animation Paper. What is the hardware requirement for it? What else should I check for?


    April 17, 2020 at 8:10 pm #2496
    Niels Krogh MortensenNiels

    Hi Ganbold, Animation Paper should run on most newer systems. I don’t think it is your hardware that is to blame for the strange thing that happens on your son’s Win10. Also reusing the key is not the problem.

    What I am noticing is that Animation Paper apparently has approved your key, but never shows the main Animation Paper window for some weird reason. Do you have an extra monitor connected? Could it be that Animation Paper opens up on another desktop or on a disabled monitor or something. Somewhere our of view?

    Is it running if you check in Task Manager?

    April 18, 2020 at 4:52 am #2497
    Ganbold TsGanbold Ts


    I tried several things. First deleted all the registry entries for Animation Paper and restarted computer. Then installed again Animation Paper and it asked key and I entered new key. It still doesn’t start, I even tried to start it from command prompt and also checked on Task manager same time when I tried to run it. It appears in task manager and then disappears. So it is like something is missing at start and exits, or maybe memory related. However on my Windows laptop (same Windows 10 pro (1909) with 32GB RAM) it just runs fine, with ~78MB memory usage. It runs fine on his old mac mini with 8GB RAM.
    So it maybe related to Windows, either something is missing or something else.
    Does Animation Paper write logs or to eventlogs in Windows? Is there anyway to debug it?


    April 18, 2020 at 5:22 am #2498
    Ganbold TsGanbold Ts

    I tried to debug it with Windbg:
    Here is the log:

    0:000> g
    ModLoad: 00007fff61f60000 00007fff61f8e000 C:\Windows\System32\IMM32.DLL
    ModLoad: 00007fff1af20000 00007fff1b098000 C:\Program Files\Animation Paper\platforms\qwindows.dll
    ModLoad: 00007fff61d20000 00007fff61de4000 C:\Windows\System32\OLEAUT32.dll
    ModLoad: 00007fff5c8d0000 00007fff5c8e3000 C:\Windows\SYSTEM32\WTSAPI32.dll
    ModLoad: 00007fff49e90000 00007fff49eb9000 C:\Windows\system32\wintab32.dll
    ModLoad: 00007fff49e60000 00007fff49e86000 C:\Program Files\Animation Paper\styles\qwindowsvistastyle.dll
    ModLoad: 00007fff4d620000 00007fff4d62f000 C:\Program Files\Animation Paper\iconengines\qsvgicon.dll
    ModLoad: 00007fff471e0000 00007fff471f1000 C:\Program Files\Animation Paper\bearer\qgenericbearer.dll
    ModLoad: 00007fff593e0000 00007fff593f6000 C:\Windows\SYSTEM32\dhcpcsvc6.DLL
    ModLoad: 00007fff593c0000 00007fff593dc000 C:\Windows\SYSTEM32\dhcpcsvc.DLL
    ModLoad: 00007fff61c70000 00007fff61d12000 C:\Windows\System32\clbcatq.dll
    ModLoad: 00007fff5c3f0000 00007fff5c42e000 C:\Windows\System32\netprofm.dll
    ModLoad: 00007fff58970000 00007fff58980000 C:\Windows\System32\npmproxy.dll
    ModLoad: 00007fff1a7c0000 00007fff1a861000 C:\Program Files\Animation Paper\libssl-1_1-x64.dll
    ModLoad: 00007fff2cc50000 00007fff2ce17000 C:\Windows\system32\d3d9.dll
    ModLoad: 0000000180000000 0000000180806000 C:\Windows\SYSTEM32\igdumd64.dll
    ModLoad: 00007fff1a610000 00007fff1a766000 C:\Windows\SYSTEM32\opengl32.dll
    ModLoad: 00007fff45ce0000 00007fff45d0c000 C:\Windows\SYSTEM32\GLU32.dll
    ModLoad: 00007fff620f0000 00007fff62226000 C:\Windows\System32\MSCTF.dll
    ModLoad: 0000000180000000 00000001811f2000 C:\Windows\SYSTEM32\ig4icd64.dll
    ModLoad: 00007fff49e50000 00007fff49e5a000 C:\Program Files\Animation Paper\libEGL.DLL
    ModLoad: 00007fff18df0000 00007fff1915d000 C:\Program Files\Animation Paper\libGLESv2.dll
    ModLoad: 00007fff5d9a0000 00007fff5db7c000 C:\Windows\SYSTEM32\dcomp.dll
    ModLoad: 00007fff5e6f0000 00007fff5e704000 C:\Windows\SYSTEM32\resourcepolicyclient.dll
    ModLoad: 00007fff4c5e0000 00007fff4cb5b000 C:\Windows\SYSTEM32\igd10umd64.dll
    ModLoad: 0000023d80580000 0000023d80d86000 C:\Windows\SYSTEM32\igdumd64.dll
    ModLoad: 0000023d80580000 0000023d80d86000 C:\Windows\SYSTEM32\igdumd64.dll
    ModLoad: 00007fff49490000 00007fff494ca000 C:\Windows\system32\dataexchange.dll
    ModLoad: 00007fff5e490000 00007fff5e6ea000 C:\Windows\system32\twinapi.appcore.dll
    ModLoad: 00007fff5e7e0000 00007fff5e809000 C:\Windows\system32\RMCLIENT.dll
    ModLoad: 00007fff482e0000 00007fff482ed000 C:\Program Files\Animation Paper\imageformats\qgif.dll
    ModLoad: 00007fff47cf0000 00007fff47cff000 C:\Program Files\Animation Paper\imageformats\qicns.dll
    ModLoad: 00007fff46d80000 00007fff46d8e000 C:\Program Files\Animation Paper\imageformats\qico.dll
    ModLoad: 00007fff45c70000 00007fff45cdb000 C:\Program Files\Animation Paper\imageformats\qjpeg.dll
    ModLoad: 00007fff45c60000 00007fff45c6c000 C:\Program Files\Animation Paper\imageformats\qsvg.dll
    ModLoad: 00007fff45c50000 00007fff45c5c000 C:\Program Files\Animation Paper\imageformats\qtga.dll
    ModLoad: 00007fff29ca0000 00007fff29d0d000 C:\Program Files\Animation Paper\imageformats\qtiff.dll
    ModLoad: 00007fff45c40000 00007fff45c4c000 C:\Program Files\Animation Paper\imageformats\qwbmp.dll
    ModLoad: 00007fff1bb50000 00007fff1bbda000 C:\Program Files\Animation Paper\imageformats\qwebp.dll
    1D textures are not supported
    (2b8c.1cd4): Access violation – code c0000005 (first chance)
    First chance exceptions are reported before any exception handling.
    This exception may be expected and handled.
    00000000`00000000 ?? ???

    So it throws Access violoation exception and says also 1D textures are not supported.
    It could be related to GUI and specially when loading qwebp.dll. Does it require Full HD resolution? Because this old thinkpad t510 is not full HD.

    Please let me know.

    April 18, 2020 at 7:15 pm #2510
    Niels Krogh MortensenNiels

    Very helpful Ganbold! Thanks! I will show this to Frederik (programmer).

    April 19, 2020 at 9:14 am #2515
    Niels Krogh MortensenNiels

    OK, Frederik says it is because of the 1D issue. We are using the GPU for various things including rendering of the drawn lines. We utilise 1D textures (one dimensional. As opposed to 2D or 3D.) Apparently your graphics card do not allow or support that.

    I’m sorry, I do not think there is much we can do about that.

    April 19, 2020 at 9:26 am #2516
    Ganbold TsGanbold Ts

    I see. It is old thinkpad t510 and has Integrated graphics.
    It is pity that it can’t run on such hardware.
    Anyhow it is good to know.

    thanks a lot,


    April 19, 2020 at 11:48 am #2519
    Niels Krogh MortensenNiels

    I hope we can find a solution somehow afterall. We might be able to do a special part of the software that does the needed 1D stuff with the CPU instead of the GPU. This would be an internal automatic feature, so it would work for people in your situation without the need for setting anything up. That’s my hope anyways. It might happen in a following alpha…

    April 19, 2020 at 11:55 am #2520
    Ganbold TsGanbold Ts

    That would be nice.
    Let me know once it becomes ready to test.



    April 19, 2020 at 9:27 pm #2521
    Niels Krogh MortensenNiels

    Hi again Ganbold. Good news! 🙂

    Frederik have worked on this problem today. Animation Paper now detects if the graphics hardware doesn’t support 1D and then uses 2D instead. So this should hopefully solve your problem. This fix will be included in Alpha 2.

    I just hope your hardware will generally be able to run Animation Paper reasonably well. At least one obstacle has hopefully been removed. 🙂

    Please let me know how it goes, when you try Alpha 2 in a few days…

    April 24, 2020 at 12:06 pm #2590
    Ganbold TsGanbold Ts

    Alpha 2 works.
    Will let you know if we find any issues.

    thanks a lot

    April 24, 2020 at 12:27 pm #2593
    Niels Krogh MortensenNiels

    That’s great! Good to know! Thanks!

You must be logged in to reply to this topic.